[IDE] 이클립스 JVM is not suitable for this product 에러 해결

이클립스를 신규 설치 후 이클립스를 실행하였더니 위와 같은 에러가 떴습니다. 위의 에러를 그대로 해석하자면 JVM 버전 15.0.2이 이 이클립스에 적절하지 않고 JVM 16 이상이 필요하다는 내용입니다. 즉 이클립스에서 필요한 JDK의 버전과 현재 PC에 설치되어있는 JDK의 버전이 다르기 때문이고 이 문제를 해결하려면 이클립스에서 요구하는 JDK와 현재 PC에 설치되어있는 JDK의 버전을 맞춰주시면 됩니다.

 

version 1.7.0_80 of the jvm is not suitable could not create the java virtual machine
이클립스 실행시 위와 같은 오류도 아래 해결방안을 통해 해결이 가능합니다.

 

해결방안

1. 이클립스를 구 버전으로 재설치한다.

2. JDK를 이클립스에서 요구하는 버전으로 재설치한다.

3. eclipse.ini의 setting을 바꾼다.

 

이 중에서 eclipse.ini의 내용을 바꾸어주는 것이 가장 편합니다.

 

elipse.ini 설정변경

1. 이클립스 설치 위치로 가서 eclipse.ini을 실행합니다.

 

2. eclipse 요구 버전을 위의 그림과 같이 내 PC에 깔려있는 JDK버전으로 바꾸어줍니다.

 

 

3. 다시 Eclipse를 실행해보면 위와 같이 정상적으로 이클립스가 실행되는것을 확인하실 수 있습니다.

댓글(0)

Designed by JB FACTORY